McLaughlin Library - Royal Society of Chemistry Journals Unavailable – Incident details

Royal Society of Chemistry Journals Unavailable

Identified
Major outage
Started 9 days ago

Affected

McLaughlin Library

Major outage from 8:45 PM to 1:37 PM, Operational from 1:37 PM to 1:50 PM, Major outage from 1:50 PM to 12:00 AM

Updates
  • Update
    UTC
    Update

    We are continuing to work on a fix for this incident. As a workaround, users can access content on the RSC platform by following these steps:

    1. Select Sign in via your Institution.

    2. On the next page, select Access through your institution

    3. In the search box enter University of Guelph. Select Next.

    4. On the next page enter your University of Guelph login credentials.

    5. Users will be brought back to the Access through your institution page, however will see UNIVERSITY OF GUELPH on the screen. This indicates that login was successful.

    6. Access content on the RSC platform through search or browsing.

    Once there is a permanent fix to this issue that does not require a workaround we will provide an update.

  • Identified
    UTC
    Identified

    Royal Society of Chemistry journals are currently unavailable for University of Guelph users, except for Open Access articles. Users will be unable to read full-text of articles that are not Open Access. Additionally, some links are leading to an endless loop of security verification screens or errors indicating "the page you're looking for cannot be found."

    We are working to resolve this issue and will provide updates as soon as possible. We apologize for any inconvenience.