McLaughlin Library - Scholars Portal Books Unavailable – Incident details

Scholars Portal Books Unavailable

Resolved
Major outage
Started 15 days agoLasted about 4 hours

Affected

McLaughlin Library

Major outage from 12:40 PM to 5:00 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Access to Scholars Portal Books is currently unavailable. We are continuing to investigate and will post an update as soon as possible. We apologize for any inconvenience.