Scheduled for October 11, 2025 at 4:00 PM – 9:00 PM
Affects
McLaughlin Library
Under maintenance from 4:00 PM to 9:00 PM
Updates
Completed
October 11, 2025 at 9:00 PM
Completed
October 11, 2025 at 9:00 PM
Maintenance is now in progress
In progress
October 11, 2025 at 4:00 PM
In progress
October 11, 2025 at 4:00 PM
Maintenance is now in progress
Planned
October 11, 2025 at 4:00 PM
Planned
October 11, 2025 at 4:00 PM
Factiva and other Dow Jones products will be undergoing scheduled maintenance on Saturday, October 11 from 12:00 PM to 5:00 PM EDT. Access will be unavailable during this time. We apologize for any inconvenience.