Fulcrum Platform Access Outage

Resolved
Operational
Started about 1 month ago Lasted about 1 hour

Affected

McLaughlin Library
Updates
  • Resolved
    Resolved

    This incident has been resolved. Thank you for your patience.

  • Identified
    Identified

    The Fulcrum platform is unexpectedly down beginning at 8:35 AM EDT this morning. The Fulcrum development team is actively working to restore service as soon as possible.

    This outage affects the following restricted collections hosted on Fulcrum:

    -ACLS Humanities Ebook (HEB)

    -British Archaeological Reports Digital Collection (BAR)

    -University of Michigan Ebook Collection (UMPEBC)

    We apologize for any inconvenience this interruption of service has caused.