JSTOR Alumni Access Outage

Resolved
Operational
Started 3 months ago Lasted about 1 month

Affected

McLaughlin Library
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We have identified an access issue with Alumni users attempting to access JSTOR. Presently, only users with an existing JSTOR account can successfully access content. Please monitor this space for updates about service status.

    Apologies for the inconvenience.