Scheduled for July 08, 2025 at 12:00 PM – 2:14 PM
Affects
McLaughlin Library
Under maintenance from 12:00 PM to 2:14 PM
Completed
July 08, 2025 at 2:14 PMCompleted
July 08, 2025 at 2:14 PMMaintenance has completed successfully.
In progress
July 08, 2025 at 12:00 PMIn progress
July 08, 2025 at 12:00 PMMaintenance is now in progress
Planned
July 08, 2025 at 12:00 PMPlanned
July 08, 2025 at 12:00 PMWe are planning for a scheduled maintenance to the PaperCut public printing and photocopying system on Tuesday, July 8, 2025 from 8am - 12noon.
During this time, public printing, public photocopying, and the PaperCut web interface will be unavailable.
We apologize for the inconvenience.