McLaughlin Library - Irwin Books Not Available – Incident details

Irwin Books Not Available

Resolved
Operational
Started 12 days agoLasted 3 days

Affected

McLaughlin Library

Operational from 8:03 PM to 1:24 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. Thank you for your patience and we apologize for any inconvenience.

  • Investigating
    Investigating

    Irwin Books are currently unavailable, and users will see an error message indicating that the page cannot be reached, or the server cannot be found.

    We are investigating this issue and will provide updates as soon as possible. We apologize for the inconvenience.