McLaughlin Library - Springer Nature Journal and Book Outage – Incident details

Springer Nature Journal and Book Outage

Resolved
Partial outage
Started 21 days agoLasted about 2 hours

Affected

McLaughlin Library

Partial outage from 2:39 PM to 4:17 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Books and journals on both the Springer and Nature platform are currently unavailable. Users will see an error message saying "Service Unavailable. Sorry, the page you requested is unavailable. Try refreshing the page in a few minutes."

    This is a widespread issue and Springer is working on it.