McLaughlin Library - Inter-Research Science Center Platform Outage – Incident details

Inter-Research Science Center Platform Outage

Resolved
Operational
Started 4 months agoLasted 28 days

Affected

McLaughlin Library

Operational from 2:02 PM to 2:36 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. We apologize for the inconvenience.

  • Identified
    Identified

    Access to content on the Inter-Research Science Center platform is currently unavailable. This issue has been reported to the vendor, and updates will be provided as they become available.