World Scientific Publishing Platform Off-Campus Access Outage
Resolved
Operational
Started 4 months agoLasted 2 days
Affected
McLaughlin Library
Operational from 8:24 PM to 5:55 PM
Updates
Resolved
Resolved
This incident has been resolved. Thank you for your patience.
Identified
Identified
Off-campus access to content on the World Scientific Publishing platform is unavailable at this time. The issue has been reported to the vendor, and updates will be provided as they become available.