McLaughlin Library - eBook Central Off-Campus Access Outage – Incident details

eBook Central Off-Campus Access Outage

Resolved
Operational
Started 5 months agoLasted 3 days

Affected

McLaughlin Library

Operational from 2:20 PM to 5:14 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. Thank you for your patience and we apologize for the inconvenience.

  • Identified
    Identified

    Off-campus access to content on the Proquest eBook Central platform is unavailable at this time, as attempts to access content leads to a error page. The issues has been reported to the vendor, and updates will be provided as they become available.