McLaughlin Library - Mary Ann Liebert Publications Off-Campus Access Outage and Linking Problem – Incident details

Mary Ann Liebert Publications Off-Campus Access Outage and Linking Problem

Resolved
Operational
Started 6 months agoLasted about 2 hours

Affected

McLaughlin Library

Operational from 2:00 PM to 4:13 PM

Updates
  • Resolved
    Resolved

    Off-campus access has been restored and journal/article linking is now working properly.

    Thank you for your patience while we worked to resolve this issue.

  • Identified
    Identified

    Access to Mary Ann Liebert publications are currently not accessible off-campus. Also, Omni links to Mary Ann Liebert journals and articles are currently resolving to the platform home page instead of the desired journal/article.

    Both of these issues have been reported as a high priority to the vendor. Users requiring access to Mary Ann Liebert content can do so on-campus by searching the Mary Ann Liebert platform for the desired journal or article.

    We apologize for any inconvenience and will work with the vendor to resolve these issues as soon as possible.