McLaughlin Library - Philosophy Documentation Center Journals Unavailable – Incident details

Philosophy Documentation Center Journals Unavailable

Identified
Major outage
Started 7 days ago

Affected

McLaughlin Library

Major outage from 6:24 PM to 12:00 AM

Updates
  • Identified
    Identified
    We are continuing to work on a fix for this incident.
  • Investigating
    Investigating

    Philosophy Documentation Center journals are currently unavailable. When attempting to access articles, users will be prompted to login with a username and password.

    We are currently working with our service providers to resolve the issue. We apologize for the inconvenience.