McLaughlin Library - Library Electronic Resource Service Disruption: Taylor & Francis eBooks — download/read options unavailable – Incident details

Library Electronic Resource Service Disruption: Taylor & Francis eBooks — download/read options unavailable

Resolved
Major outage
Started 13 days agoLasted about 22 hours

Affected

McLaughlin Library

Major outage from 5:30 PM to 3:09 PM, Operational from 1:51 AM to 3:09 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update
    We are currently investigating this incident.
  • Investigating
    Investigating

    Some Taylor & Francis e-books are currently not displaying “Read Online” or “Download” buttons. Users may see only abstracts and metadata.

    This issue has been reported to the vendor, and we’re working with them to restore full access. We will provide updates as they become available. We apologize for the inconvenience.