McLaughlin Library - Canada Post Strike Will Delay Some Requested Items – Incident details
All systems operational
Canada Post Strike Will Delay Some Requested Items
Resolved
Degraded performance
Started 3 months agoLasted 2 months
Affected
McLaughlin Library
Degraded performance from 2:54 PM to 4:36 PM
Updates
Resolved
Resolved
This incident has been resolved.
Monitoring
Monitoring
Due to the Canada Post strike, we may experience delays on receiving requested items that we have to source from libraries outside the Omni Network. Alternative shipping options will be pursued wherever possible and we will keep patrons informed if their request is delayed. We apologize for any inconvenience.