McLaughlin Library - Canada Post Strike will Delay Some Requested Items – Incident details

Canada Post Strike will Delay Some Requested Items

Monitoring
Operational
Started about 1 month ago

Affected

McLaughlin Library

Operational from 7:15 PM to 12:00 AM

Updates
  • Monitoring
    Monitoring

    Canada Post workers have been ordered to resume work by the federal government. We anticipate that it will take the corporation several weeks to work through the backlog of items and to resume postal deliveries in all regions.

    Interlibrary Loan shipments will not resume before January 6, 2025. We apologize for any inconvenience.

  • Identified
    Identified

    Due to the Canada Post strike, we may experience delays on receiving requested items that we have to source from libraries outside the Omni Network. Alternative shipping options will be pursued wherever possible and we will keep patrons informed if their request is delayed. We apologize for any inconvenience.