Scheduled for March 01, 2024 at 10:00 PM – March 02, 2024 at 1:00 AM
Affects
McLaughlin Library
Under maintenance from 10:00 PM to 1:00 AM
Updates
Completed
March 02, 2024 at 1:00 AM
Completed
March 02, 2024 at 1:00 AM
Maintenance has completed successfully
In progress
March 01, 2024 at 10:00 PM
In progress
March 01, 2024 at 10:00 PM
Maintenance is now in progress
Planned
March 01, 2024 at 10:00 PM
Planned
March 01, 2024 at 10:00 PM
Databases hosted on the Fulcrum platform, including ACLS Humanities Ebook (HEB) and University of Michigan Ebook Collection (UMPEBC), will be unavailable for approximately 3 hours starting Friday March 1st at 5:00pm EST due to scheduled maintenance.